Video Player

26 replies [Last post]
wogens10's picture
User offline. Last seen 2 years 5 weeks ago. Offline
Joined: Aug 30 2010

Hey Beer Baron and Explicit D (well mostly BB because he's doing all the work),

I am experiencing some problems with the video player you are using. The videos seem to freeze at one exact spot every time I watch them (e.g. Killzone 3 Lets Play Part 3). I tried refreshing, but it freezes at the same spot. Also, the video player seems to have trouble fast forwarding or skipping to a specific spot.

If you guys are making profit from using this video player, then I'll understand and stop bitching. If not, then please change the video player to something else like YouTube, which works the best for me. OR you could try making your own like CollegeHumor did.

Thanks for reading, your website and videos are awesome.

GTAComplete's picture
User offline. Last seen 4 years 11 weeks ago. Offline
Joined: Mar 10 2011

That IS the YouTube player. YouTube's embed player is all <iframe></iframe embedded now, instead of direct <object><embed></embed></object> like it used to be.

John Tarr's picture
User offline. Last seen 16 weeks 4 days ago. Offline
Joined: Aug 3 2010

If you guys are making profit from using this video player, then I'll understand and stop bitching

The video player I'm using for the KZ3 vids (and most of my guides) is a proprietary player that does in fact earn us money via preroll ads. The fact that we're stuck using something other than the best player (YouTube) doesn't mean I'm not concerned that it's not working correctly.

wogens, could you tell me your operating system and browser? What point does the video freeze? And is it only KZ3 Part 3, or every video?

Whiplash's picture
User offline. Last seen 1 year 10 weeks ago. Offline
Joined: Oct 14 2010

Fixing the problem while watching the video is easy. All you do is lower or raise the video quality and set it back to what you were watching in before.

wogens10's picture
User offline. Last seen 2 years 5 weeks ago. Offline
Joined: Aug 30 2010

hey BB my computer is 32 bit Windows Vista (yeah i know its really shitty) and I use Google Chrome. I encountered the problem on all videos, but Whiplash's solution above fixed most of them. Thanks for your consideration though. Also thanks to Whiplash for the solution.

P.S.: Here's a tip. Upload the whole Drink Along series for Killzone 3 on Youtube. They have been getting quite some views.

GTAComplete's picture
User offline. Last seen 4 years 11 weeks ago. Offline
Joined: Mar 10 2011

That... IS A TERRIBLE IDEA. They'd wouldn't make as much money.

John Tarr's picture
User offline. Last seen 16 weeks 4 days ago. Offline
Joined: Aug 3 2010

I only uploaded 2 KZ3 videos (very intentionally) to YouTube as a teaser to get people to watch the rest on this site (and like GTAComplete said, we don't earn a penny from YT views)

Jevrio's picture
User offline. Last seen 40 weeks 1 day ago. Offline
Joined: Mar 16 2011

What is the other site? Blip.tv?

Is commentary needed to put videos at that place and making money on it?

GTAComplete's picture
User offline. Last seen 4 years 11 weeks ago. Offline
Joined: Mar 10 2011

What is the other site? Blip.tv? Is commentary needed to put videos at that place and making money on it?

Indeed, it is.

John Tarr's picture
User offline. Last seen 16 weeks 4 days ago. Offline
Joined: Aug 3 2010

The site we use isn't open to public uploads(private contract & partnership with blastro.com)...but blip.tv does let you earn $ from uploads (and you can easily add those videos on this site)

GTAComplete's picture
User offline. Last seen 4 years 11 weeks ago. Offline
Joined: Mar 10 2011

Yeah, what Beer_Baron said. I always use Blip.tv

Jevrio's picture
User offline. Last seen 40 weeks 1 day ago. Offline
Joined: Mar 16 2011

I've tried it a bit, but it pisses me off that you have to watch a commercial before watching the video. And no HD (atleast not unless you pay, or gets it some other way).

However, I could try to upload some videos there (maybe re-encode to 480p so faster), and see if it's any good. But there don't seem to be any "channel" system there..

bip267's picture
User offline. Last seen 3 years 49 weeks ago. Offline
Joined: Aug 10 2010

Just wanted to say that although i did everything that you guys said to fix the video problems, it still isnt workings.  I can only watch a quarter of the video, and when I go to change the quality the video, it stops working, no matter what i do and when I do it.

John Tarr's picture
User offline. Last seen 16 weeks 4 days ago. Offline
Joined: Aug 3 2010

@bip267 could you post your OS & browser?

Getting it fixed is kinda out of our hands, but the more information I can provide to Blastro about why their player isn't working, the better.

torment's picture
User offline. Last seen 1 year 49 weeks ago. Offline
Joined: Apr 6 2011

Hello, guys

Nice site upgrade :)

Can't u use html5 ? i wan't to view the video's on my ipad...

Red_Baron2011's picture
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: Apr 4 2011

There were two other concerns i had about the video player. First, on both the iphone and pc, the videos don't always load up the first time you click the arrow, and then they freeze so they wont even play at all so you have to click on the same page again to see if it'll work.

second, on the iphone, once a video has been seen all the way, you can't rewatch it, only go to the next one, without going to the same page again. i'm not sure if this also happens on the pc also. if it can't be fixed it's understandable though.

John Tarr's picture
User offline. Last seen 16 weeks 4 days ago. Offline
Joined: Aug 3 2010

Can't u use html5 ? i wan't to view the video's on my ipad...

Our player does work on iPhones/iPads.

 on both the iphone and pc, the videos don't always load up the first time you click the arrow

Yea I'm noticing this more and more recently. I don't know why but the player seems to be getting less and less reliable lately.

 you can't rewatch it

Good point. I'll put in a request for a replay button.

Red_Baron2011's picture
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: Apr 4 2011

the player is much more reliable now and the replay button is really nice.

Insert_Brain's picture
User offline. Last seen 5 years 19 weeks ago. Offline
Joined: Apr 17 2011

hey, fyi i dont know if its just me but the videos for metal gear solid 4 dont seem to load or play at all.

My system is a 32 bit Windows 7, and i use both IE9 and Firefox.

p.s. keep up the good work, the site is awesome

John Tarr's picture
User offline. Last seen 16 weeks 4 days ago. Offline
Joined: Aug 3 2010

@insert is it only the MGS4 vids that are not working for you? Which vids specifically? And do our Drink Along vids work? http://wikigameguides.com/Killzone_3/Guides/Drink_Along_wDan_and_John

Insert_Brain's picture
User offline. Last seen 5 years 19 weeks ago. Offline
Joined: Apr 17 2011

My apologies for the late reply. After retrying the vids, i have found they are now all (including the drink along ones) working on IE9, but fail to on Firefox (again including the drink along ones), the MGS4 trailer vids work fine, just the actual boss extreme guide does not. I press play then .......... nothing. Could it be that im using Firefox 4??

At least im now able to watch them on IE XD

Dogbond's picture
User offline. Last seen 4 years 17 weeks ago. Offline
Joined: Apr 24 2011

Well I dunno what you guys did but thankfully the player is finally (mostly) working for me, like others I had great problems with the player not doing anything after clicking the arrow, but now all I have to deal with is the buffer bar not showing up sometimes or the progress pointer not showing up, still it's better than the videos not even loading!

tajboy123's picture
User offline. Last seen 4 years 8 weeks ago. Offline
Joined: Jan 27 2011

hey there is something wrong with the videos like fallout 3 it show music videos instead the videos themslevers

Mango's picture
User offline. Last seen 1 year 34 weeks ago. Offline
Joined: Jan 17 2011

I'm geting really bad rap music videos for just about every video on the site.

Elogrey's picture
User offline. Last seen 5 years 17 weeks ago. Offline
Joined: May 6 2011

I'm trying to watch your portal 2 videos but all im getting is rap music videos.

jreinKs's picture
User offline. Last seen 1 year 18 weeks ago. Offline
Joined: Feb 3 2011

Yeah, I'm getting the same shit, just sent him (BeerBaron) a message bout it, I guess its on all of them?

John Tarr's picture
User offline. Last seen 16 weeks 4 days ago. Offline
Joined: Aug 3 2010

All the videos with our custom player went completely screwy today, showing music videos instead of the videos you were expecting. They should all be back to normal now.